invisible dataframes
debug
commands is growing!
debug
, our old loyal friendinspect
, thinking about renaming to explain
. PR 7957view source
, same command just renamed without the dash. PR 7989view span
, give you the ability to view spans. PR 7989view files
, shows what's in the engine_state files vec. PR 7989profile
, times each line of a script and shows you. PR 7854nu_plugin_dbg
, looking for a better name, shows description and values. Darren's repobenchmark
, times scripts, no changesNot sure if we'll do anything with this for now, but JT has a feeling that we might eventually; the "nushell" name probably deters a lot of people who don't realize it's a programming language
Stefan: got pretty far but there's some issue with the tooling, where it can't do a final merge of the coverage data on macOS
Maybe we just do code coverate on Ubuntu (and Windows?)
JT was able to make a small app that runs a single script
replace create_default_context
and use only those commands needed and include_str
the script
Tree-shaking of dependency only happens at the last step/linking (so still >400 crates to compile)
open foo.exe
does not display nicely, need to do into binary
and it does not stream
TODO: should into binary
stream?
Naming: should we avoid view
in the names? dbg
?
JT:
-benchmark
name is too long to type.
- What if we allowed benchmark
at the end of a pipeline instead of using a closure? But that won't capture the time to calculate parameters
JT looked into Polars/Arrow/Datafusion more, nothing seems like it's a great fit for streaming data
df open "foo.csv" | where name = bar
idea: Liskov Substitution Principle as applied to Nu command overloading
Nushell is not trying to be a perfect data science/processing platform for everyone; little more focus on the programming+shell sides
engine-q afterthought: separating the containers/streams (i.e. transport types) from the primitive types would be better than the PipelineData
/Value
split we have now (we have to repeat a bunch of container broadcasting code. typechecking in multiple places.)
Adding dataframe/sql etc. would be primarily on the transport/container layer
Reilly: how do we ensure that overloaded commands are functionally the same as the base version? i.e. differences in flags
Stefan: are commands the right abstraction?
Command::run
JT's brain, late at night: "objects, modules, records are all the same thing"
JT thinks we should do the renaming now and work toward a better overloading solution later
Vote: Land and iterate with more plugins!
or
or
By clicking below, you agree to our terms of service.
New to HackMD? Sign up
Syntax | Example | Reference | |
---|---|---|---|
# Header | Header | 基本排版 | |
- Unordered List |
|
||
1. Ordered List |
|
||
- [ ] Todo List |
|
||
> Blockquote | Blockquote |
||
**Bold font** | Bold font | ||
*Italics font* | Italics font | ||
~~Strikethrough~~ | |||
19^th^ | 19th | ||
H~2~O | H2O | ||
++Inserted text++ | Inserted text | ||
==Marked text== | Marked text | ||
[link text](https:// "title") | Link | ||
 | Image | ||
`Code` | Code |
在筆記中貼入程式碼 | |
```javascript var i = 0; ``` |
|
||
:smile: | ![]() |
Emoji list | |
{%youtube youtube_id %} | Externals | ||
$L^aT_eX$ | LaTeX | ||
:::info This is a alert area. ::: |
This is a alert area. |
On a scale of 0-10, how likely is it that you would recommend HackMD to your friends, family or business associates?
Please give us some advice and help us improve HackMD.
Syncing