or
or
By clicking below, you agree to our terms of service.
New to HackMD? Sign up
Syntax | Example | Reference | |
---|---|---|---|
# Header | Header | 基本排版 | |
- Unordered List |
|
||
1. Ordered List |
|
||
- [ ] Todo List |
|
||
> Blockquote | Blockquote |
||
**Bold font** | Bold font | ||
*Italics font* | Italics font | ||
~~Strikethrough~~ | |||
19^th^ | 19th | ||
H~2~O | H2O | ||
++Inserted text++ | Inserted text | ||
==Marked text== | Marked text | ||
[link text](https:// "title") | Link | ||
 | Image | ||
`Code` | Code |
在筆記中貼入程式碼 | |
```javascript var i = 0; ``` |
|
||
:smile: | ![]() |
Emoji list | |
{%youtube youtube_id %} | Externals | ||
$L^aT_eX$ | LaTeX | ||
:::info This is a alert area. ::: |
This is a alert area. |
On a scale of 0-10, how likely is it that you would recommend HackMD to your friends, family or business associates?
Please give us some advice and help us improve HackMD.
Syncing
xxxxxxxxxx
Nushell core team meeting 2022-11-16
Attendees
Agenda
Discussed Topics
Observations before the scheduled agenda
table --expand
is going great (and with thedisplay_hook
you can expand it based on terminal size)This release packaging was quick
GitHub nu(shell) integration
nu extension still refers to the objective-C lisp
.nu
We are starting to reach critical mass to reach out to github/linguist for
.nu
as nushellNeeds 200 repos
https://github.com/github/linguist/blob/master/CONTRIBUTING.md#adding-a-language
Plans for parser changes
JT's thinking of landing small incremental changes instead of a big bang
- will support bashisms like >, &&, ||. some changes to the pipeline data structure needed (can no longer be a simple `Vec<Command>``)
Experiment now archived
Trimming down commands
n
,p
)Darren's command spreadsheet: https://docs.google.com/spreadsheets/d/1w8FWy7FXhkiIQ7EJN0wF8SdDWImGwVwxywEg85LJtpU/edit#gid=0
Please put in your hottakes: commands that can be useably replaced, renaming to consistency (also inspect flags)
Dan: we can still make breaking changes and can really reflect on the state of the standard library
Stefan: should strike the right balance between combining a million tiny commands and using 1 big bloated command with 100 flags
JT: latent fear that we loose momentum but we should feel comfortable to make the breaking changes! we are in a reflective period to inspect naming/organization. No we have momentum for the editorial process and reviewing -> let's do it
Help get users down the happy paths -> help with common patterns
Darren: removing commands is hard when we lose functionality, tough decisions to make. is it OK to lose functionality like shells?
JT:
from ...
:parse
read
convert
load(s)
to ...
:serialize
write
format
dump(s)
read
/write
file vs pipeDan:
to
andinto
are confusingThe pair for file format parsing is core to nushell functionality + casting/interconversion
JT:
Steady stream of breaking changes vs. ripping the bandaid in a batch
Consensus: At least make the topical changes together
Maybe rename the
from
/to
pair to something and maketo
the casting command (most languages seem to haveTo...
methods/functions)Plugin update
JT: been thinking about options for plugins: new plugin system (WASM? DLLs?) vs augmenting the existing plugin system incrementally. Leaning toward incremental
Jakub: agrees w/ incremental
Stefan: agrees w/incremental from risk and community perspectives
Darren: Gonna need a big jump in functionality to do things like dataframes in plugins
Michael: Need to get Fernando's input and consult him on the future of dataframes
JT: we should remove complicated parts that don't have enough maintenance energy behind them. maybe we put out a survey asking how many people are actually using dataframes
-> Action Item: community survey about dataframes (Michael, JT)
Input output type signatures
Jakub's exploration
JT's notes:
gradual progression in the type stringency (we currently have opaque types, moving to wards structural types, + named parts in the structure. + type aliases/ "structs")
(one-liner to) Scripts to programs
Q: WindSoilder: How stringent should we be for the input type.
Can we infer based on the implementation or do we assume
Any
if not given.$in
is kind of overused as a name(additional reserved name
input
as a potential solution to clarify)PR's
Open for discussion
Triage if necessary, fill in small details if you are sheparding the PR
-n
flags) (@webbedspace)url parse
(#6854) andurl
subcommands tests (@raccmonteiro)first
andlast
always return 1 element, lettake
return from end of list (@rgwood)Looking for reviewers
In process, no need for the full team
Pull out of here if you have concerns
lines
reads bad bytes (@merelymyself)seq
return aListStream
where possible. (@merelymyself)less
like pager (@zhiburt)from ...
commandsfrom json
to nuon
(closes #6989) (@webbedspace)Cold:
Only discuss if closing vs waiting is contentious
append
implementation. weird conversion when mixing tables with other lists