Josh will check on the status of this and we can discuss in the lang meeting tomorrow.
(nominated) rust.tf/130703Tracking Issue for secure random data generation in `std`
Discussion on returning errors vs panicking
Josh: it sounds like the lowest-level random source API needs to support returning error, and when we design the higher-level API for things like "roll a D6" (inspired by rand_core) we can definitely consider panicking in those
(nominated) rust.tf/137198Rename `cfg_match!` to `cfg_select!`
In FCP as of 2 weeks ago on the tracking issue, agreed to close the rename PR
We're not sure what the difference in terms of exposed behavior is, and we'll ask about that. If we weren't to do this, it seems based on the discussion in the issue that this would be exposing part of "macros 2.0" for the first time, and that would need a lang FCP.
(nominated) rust.tf/137654Debug impls of ExtractIf have inconsistent trait bounds
Waiting on David to send:
hashbrown PR
rust standard library hashbrown update
standard library API PR
(waiting on team) rust.tf/134446Stabilize the `cell_update` feature
Waiting on FCP
(waiting on team) rust.tf/136687Improve the documentation of `Display` and `FromStr`, and their interactions
Deferring for a longer discussion
(waiting on team) rust.tf/136912Add missing trait implementations for ScopedJoinHandle
Waiting on author
(waiting on team) rust.tf/137487Stabilize `assert_matches` and move it to `core::macros`
Related: rust.tf/139493– David to propose a way to avoid putting vec module into prelude
(new change proposal) rust.tf/libs571implement `Default` for raw pointers
(new change proposal) rust.tf/libs570actually checked bitshifts
(new change proposal) rust.tf/libs569ACP: abstract `BufReader::peek`
(new change proposal) rust.tf/libs568Implement `Read` and `Write` traits for `BorrowedFd` and `OwnedFd`
Approved; Josh to write comment.
(new change proposal) rust.tf/libs562Add ability to customize STARTUPINFO structure in Command API
(new change proposal) rust.tf/libs559Expose `.set_flags()` on Posix `CommandExt `
(new change proposal) rust.tf/libs557Add `iter::Peekable::next_unpeek`
David's counterproposal: no new Unpeeker type, no ambiguity about what happens if the peek slot is already filled when you unpeek
impl<I:Iterator>Peekable<I>{fnbikeshed(&mutself)->&mutOption<I::Item>;}let peek_slot = peekable.bikeshed();ifletSome(value)= peek_slot.take(){ifbad(&value){*peek_slot =Some(value);// unpeek}}else{// end of iterator}
(new change proposal) rust.tf/libs555Add `std::io::Seek` instance for `std::io::Take<T>` when `T: Seek`
(new change proposal) rust.tf/libs554Add `std::process::Output::exit_ok`
(new change proposal) rust.tf/libs553Add a "shrink-if-excessive" API to `Vec`