# Libs-API Meeting 2022-10-25 ###### tags: `Libs Meetings` `Minutes` **Meeting Link**: https://meet.jit.si/rust-libs-meeting-crxoz2at8hiccp7b3ixf89qgxfymlbwr **Attendees**: Amanieu, David, Mara, thomcc, Chris Denton, The 8472, Vincent ## Agenda - Triage - Anything else? ## Triage ### FCPs 16 rust-lang/rust T-libs-api FCPs [joshtriplett (4)](https://rfcbot.rs/fcp/joshtriplett), [Amanieu (2)](https://rfcbot.rs/fcp/Amanieu), [dtolnay (4)](https://rfcbot.rs/fcp/dtolnay), [BurntSushi (12)](https://rfcbot.rs/fcp/BurntSushi), [yaahc (11)](https://rfcbot.rs/fcp/yaahc), [m-ou-se (7)](https://rfcbot.rs/fcp/m-ou-se) ### Nominated - [1 `rust-lang/libs-team` `T-libs-api` `I-nominated` items](https://github.com/rust-lang/libs-team/issues?q=label:T-libs-api+label:I-nominated+is:open) - github.com/rust-lang/libs-team/issues/122 *Revamp unstable MaybeUninit APIs* - Ongoing discussions. - David notes: last meeting we discussed `transpose()`, which we didn't find very readable in the last meeting. - [5 `rust-lang/rust` `I-libs-api-nominated` items](https://github.com/rust-lang/rust/issues?q=label:I-libs-api-nominated+is:open) - rust.tf/95985 *Add PhantomData marker to Context to make Context !Send and !Sync* - Pinged wg-async for input. - rust.tf/101179 *Deprecate uninit\_array* - Discussed and replied to last week. - Removed nominated label. - rust.tf/101899 *#95295 causes unsoundness in multiple existing crates* - Just needs a comment. The revert will not go into beta/nightly. Relnotes label has been placed on the right PR last week. - rust.tf/102737 *poll\_fn and Unpin: fix pinning* - Let's merge. FCP kicked off. - rust.tf/102935 *Fix inconsistent rounding of 0.5 when formatted to 0 decimal places* - Seems like a bug fix, doesn't require an FCP if there was no good reason for the old behaviour and this was just a bug. - Mara to review. - [1 `rust-lang/rfcs` `I-libs-api-nominated` items](https://github.com/rust-lang/rfcs/issues?q=label:I-libs-api-nominated+is:open) - rust.tf/rfc3271 *RFC: Add more support for fallible allocations in Vec* - Ongoing discussion. ### Waiting on team - [2 `rust-lang/rust` `T-libs-api` `S-waiting-on-team` items](https://github.com/rust-lang/rust/issues?q=label:T-libs-api+label:S-waiting-on-team+is:open) - rust.tf/99032 *Disable unwinding for \`catch\_unwind\` error payloads.* - rust.tf/102977 *remove HRTB from \`\[T\]::is\_sorted\_by{,\_key}\`* - ACP: https://github.com/rust-lang/libs-team/issues/121 - This change looks fine. - Can we do the same for sort_by_key? - Nope. :( Would be unsound. (Especially clear with 'static.) - `F: for<'a> ... + 'a` would be nice, but we can't do that today. ### Needs decision None ### Stalled Tracking Issues https://github.com/rust-lang/rust/issues?q=label:T-libs-api+label:C-tracking-issue+is:open+sort:updated-asc ### ACPs Rename AtomicPtr::fetch_ptr_{add,sub} to AtomicPtr::fetch_{add,sub}: https://github.com/rust-lang/libs-team/issues/126 On regular pointers we have `add` and `byte_add`, but for AtomicPtr we have `fetch_ptr_add` and `fetch_byte_add`. `fetch_add` might be confusing, but would be more consistent. It's quite common to use AtomicPtr for something that contains both a pointer and flags.